Our Engineering team has been actively monitoring and testing all Knack services, and we’re happy to report that functionality has returned to normal.
The underlying AWS incident remains open as their teams continue to run additional tests and validations, but Knack appears to be fully recovered from the impact.
Thank you for your patience while this was resolved.
Posted Oct 20, 2025 - 17:47 EDT
Monitoring
We’re starting to see apps and services come back online as AWS systems recover from the earlier outage. You may still experience some slowness or intermittent issues as traffic ramps back up and everyone reconnects. Our team is continuing to monitor performance closely to ensure stability across all systems.
We’ll share another update once everything is fully operational. Thank you for your patience and understanding!
Posted Oct 20, 2025 - 16:39 EDT
Identified
We’re currently experiencing service disruptions due to a broader issue impacting Amazon Web Services (AWS), one of our key infrastructure providers. AWS engineers are actively working to resolve the incident, and we’re closely monitoring their progress.
Our team will continue to provide updates here as more information becomes available. Thank you for your patience while we work through this.
Posted Oct 20, 2025 - 13:28 EDT
Update
We’ve identified that the slowdown and partial service disruption initially reported in the US region is now affecting multiple regions. The root cause remains an issue with one of our upstream providers.
We’ll continue to share updates here as we make progress. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 12:48 EDT
Investigating
Some of our customers in the US region might be experiencing slowdown or partial service disruption. We have identified an upstream provider as the source and we are working with them to get this resolved. We will keep you updated!
Posted Oct 20, 2025 - 10:29 EDT
This incident affected: Knack Features (Builder, Live App, API).