Next Gen App Page Loading Issues

Incident Report for Knack

Resolved

Our team identified the root cause of the problem affecting page loading in the Builder and Live App. The issue has been resolved, and functionality should be back to normal now. If you continue to experience any problems, please refresh your browser or contact support.

Thanks for your patience while we worked to fix this!
Posted Jul 08, 2025 - 14:49 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 14:33 EDT

Investigating

Some customers are seeing "Uh oh! This page does not exist" when loading pages in the Builder and Live App. Our team is investigating and working to restore service.

Thanks for your patience while we resolve this issue.
Posted Jul 08, 2025 - 14:01 EDT
This incident affected: Knack Features (Builder, Live App).