Builder and Live App not accessible- All regions affected

Incident Report for Knack

Postmortem

During routine system maintenance, we performed an infrastructure update intended to improve performance. While no downtime was expected, an issue arose when certain instances were temporarily assigned new IP addresses. This led to a brief disruption in inter-service communication.

The issue was quickly identified and resolved by updating the necessary DNS records and restarting supporting components. We’ve also identified preventative measures to ensure this does not recur in future maintenance windows.

Posted Apr 20, 2025 - 14:37 EDT

Resolved

The issue is resolved on our end and the services are back online at the moment. We appreciate everyone's patience while we worked on finding a solution.
If you have any more issues with the services, please reach out to support@knack.com.
Posted Apr 15, 2025 - 03:00 EDT

Investigating

We have discovered that the Builder and Live app services are not loading at the moment. Our engineering team is already aware of the situation and the investigation is ongoing.
Once we have more details we will be posting an update.
Posted Apr 15, 2025 - 02:14 EDT
This incident affected: Knack Features (Account Dashboard, Builder, Live App, API).